for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Л и с о в о д ы   в с е х   с т р а н,  о б ъ е д и н я й т е с ь !!!  

Список Форумов  :: Вопросы по 1С
   :: Помощь сайту :: 

Передача параметра в запрос Com
Зингер

Сообщений: 520
Откуда: Белгород
Дата: 25.12.16 09:12:46ОтветитьЦитировать
Вроде бы простой запрос. Без Кома отрабатывает без проблем. Здесь же результат количество=0. Без параметра количество=реальному.
  
  &НаКлиенте  
  Процедура ПроверитьОстаткиВ1(Команда)  
  	Запрос =КомОбъект.NewObject("Запрос");  
  	Запрос.Текст =   
  	"ВЫБРАТЬ  
  	|	ТоварыНаСкладахОстатки.КоличествоОстаток КАК Кол,  
  	|	ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура  
  	|ИЗ  
  	|	РегистрНакопления.ТоварыНаСкладах.Остатки(, Номенклатура=&Номенклатура) КАК ТоварыНаСкладахОстатки  
  	|УПОРЯДОЧИТЬ ПО  
  	|	Номенклатура,  
  	|	Кол";  
  	Запрос.УстановитьПараметр("Номенклатура",ПолучитьКодНоменклатуры(Объект.Номенклатура));  
  	РезультатЗапроса = Запрос.Выполнить();  
  	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();  
  	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл  
  		Сообщить(ВыборкаДетальныеЗаписи.Кол);  
  	КонецЦикла;  
  КонецПроцедуры  
    
  &НаСервереБезКонтекста  
  Функция ПолучитьКодНоменклатуры(Номенклатура)  
      Возврат Номенклатура.Код;  
  КонецФункции

Помогите пож-та. Бьюсь уже часов 10.
Ratings: 0 negative/0 positive

Re: Передача параметра в запрос Com
pasha_usue
Автор

Сообщений: 2916
Откуда: Е-бург
Дата: 25.12.16 17:15:21ОтветитьЦитировать
В запросе вы проверяете значение ссылочного типа "Номенклатура" на равенство значению текстового типа "Код". Я бы тоже вам фигу показал на месте движка.

Либо получайте ссылочный тип из базы источника и его передавайте в запрос. Либо в запросе сравнивайте текстовое поле код с текстовой строкой (код).
Ratings: 0 negative/1 positive



Извините, только зарегистрированные пользователи могут писать в этом форуме.

On-line: 34 and Guests: 34


© 2000-2018 Fox Club 
Яндекс.Метрика