for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Re: Отлов ошибки в фоновом задании
Аспид
Автор

Сообщений: 3293
Откуда: Москва
Дата: 16.08.16 15:29:02
Увы. написал.
  
  Процедура ПроверкаВыводаФоновыхЗаданий() Экспорт  
    
  	Если мСписокФоновыхЗаданий.Количество()= 0 Тогда  
  		  
  		ОтключитьОбработчикОжидания("ПроверкаВыводаФоновыхЗаданий");  	*Здесь точка останова  
  	Иначе  
  		АсинхронныеОбработчикиСервер.ПроверитьВыводФоновыхЗаданий(мСписокФоновыхЗаданий);  
  	  
  	КонецЕсли;  
  	  
  КонецПроцедуры

Так вот, продолжает крутиться(
Может потому, что из самого себя отключаю. А как по другому?
Другого клиента нет.
Создать еще процедуру клиентскую, которая будет отключать, но вызываться то будет все равно из этого обработчика.
Опять запутался(


------------------
Ratings: 0 negative/0 positive

Re: Отлов ошибки в фоновом задании
Аспид
Автор

Сообщений: 3293
Откуда: Москва
Дата: 17.08.16 09:16:59
С ОтключитьОбработчикОжидания кажется разобрался.
Вешаю на обработку, из которой запускаю ПодключитьОбработчикОжидания, кнопку отключить, и там выполняю ОтключитьОбработчикОжидания.
Все отключается.

Попробовал ход конем.
В глобальном модуле
  
  Процедура ЗапускСОтключеним()  Экспорт  
    
  	ПодключитьОбработчикОжидания("КонтрольФЗСОтключением",1);  
    
  КонецПроцедуры
И из обработки, запускаю ЗапускСОтключеним()
Увы, не помогло(

Все же, как то ПодключитьОбработчикОжидания и ОтключитьОбработчикОжидания, завязаны на 1 объект.
(Вполне может, и логично, для общих случаев)


------------------




Исправлено: Аспид, 17.08.16 09:20
Ratings: 0 negative/0 positive

Re: Отлов ошибки в фоновом задании
pasha_usue

Сообщений: 3108
Откуда: Е-бург
Дата: 17.08.16 12:02:21
Да что-то я сам запутался. Из невидимого. Добавлен код "модуля сеанса" и убран код "модуля управляемого приложения". Добавлен ПараметрСеанса "СписокФоновыхЗаданий", так как я хотел избавиться от глобальной переменной, которая "здесь вижу, здесь не вижу".

И не смог оформить вызов "АсинхронныеОбработчикиСервер.ПроверитьВыводФоновыхЗаданий" функцией, она тупо не вызывалась из глобального модуля. Не стал разбираться, почему.
Ratings: 0 negative/0 positive

Re: Отлов ошибки в фоновом задании
Аспид
Автор

Сообщений: 3293
Откуда: Москва
Дата: 18.08.16 11:43:44
Спасибо.
Разбираюсь)
В общем, ты классно все изолировал.

Но ты знаешь, я пока остановился на твоем 1м коде.
Если там оформить

  
  	Если мСписокФоновыхЗаданий.Количество()> 0 Тогда    
  		  
  		_АсинхронныеОбработкиСервер.ПроверитьВыводФоновыхЗаданий(мСписокФоновыхЗаданий);  
  		  
  	КонецЕсли;

то оверхед, ну совсем, мне кажется грошовый.
И главное, посмотрел, профи так делают.

А самое главное, уж очень там все понятно)))
И уже придумал, как другое туда прикрутить можно.


------------------
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 13 (Гостей: 13)

18.06.2019 10:18:13 exec: 0.07
Mem: 1.164 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика