for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Бухгалтерские итоги. Периодичность
mmm-mirsobit
Автор

Сообщений: 34
Откуда: Ташкент
Дата: 08.05.15 18:29:27
Здравствуйте!
у меня 1с 7.7.
создал отчет по пенсионным взносам граждан.
отчет ежеквартально сформируется.
графы отчеты:
1. ФИО
2. ИНН
3. суммы взноса с начала года до настоящего квартала
4.5.6. сумма взноса за 1-2-3-й месяца текущего квартала
7. общая сумма взноса в ПФ с начала года, т.е. гр.3+гр.4+гр.5+гр.6
текс модула:

НачУд=СоздатьОбъект("Справочник.НачисленияИУдержания");  
  	НачУд.НайтиПоКоду("1020");  
  	Взнось=НачУд.ТекущийЭлемент();  
  	Таб = СоздатьОбъект("Таблица");  
  	Таб.ИсходнаяТаблица("Свод");  
    
  	Ит = СоздатьОбъект("БухгалтерскиеИтоги");  
  	Ит.ИспользоватьСубконто(ВидыСубконто.НачУд,Взнось,2);  
  	Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники);  
  	Ит.ВыполнитьЗапрос(НачГода(ДатаН1мес),ДатаК3мес,,,,2,"Месяц","С");  
    
  	Таб.ВывестиСекцию("Шапка");  
  	Ит.ВыбратьСубконто(ВидыСубконто.Сотрудники);  
  	НомПП=0;  
  	Пока Ит.ПолучитьСубконто(ВидыСубконто.Сотрудники) = 1 Цикл  
  		Если Ит.ДО()<>0 Тогда  
  			НомПП=НомПП+1;  
  			сум1м=Ит.ДО();    // сумма взноса за 1-й месяц квартала  
  			сум2м=Ит.ДО();    // сумма взноса за 2-й месяц квартала  
  			Сум3м=Ит.ДО();    // сумма взноса за 3-й месяц квартала  
  			Таб.ВывестиСекцию("Строка");  
  		КонецЕсли  
  	КонецЦикла;  
  	Таб.ВывестиСекцию("Подвал");  
  	Таб.ТолькоПросмотр(1);  
  	Таб.Показать("Сформировать","");  
  КонецПроцедуры

как мне получить бух.итоги за определенный месяц?
в книге написано, что
Ит.ВыполнитьЗапрос(НачГода(ДатаН1мес),ДатаК3мес,,,,2,"Месяц","С");
<Периодичность> - число или символьная строка (см. документацию).Позволяет получить дополнительный разрез итогов по периодам. По умолчанию периодичность не задана.
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 28 (Гостей: 28)

19.06.2019 06:33:24 exec: 0.08
Mem: 1.055 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика