for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Поиск конфиги
ssa
Автор

Сообщений: 12329
Откуда: Москва
Дата: 29.03.14 15:00:45
Имеется внешняя обработка вот с таким вызовом:
ПолноеНазначениеЗначение = ДополнительныеОтчетыИОбработки.ПолучитьПолноеНазначениеПоВидуДополнительнойВнешнейОбработки(ВидОбработки);
Судя по последующему коду ПолноеНазначениеЗначение есть ТЗ.

Так вот ни в одной из имеющихся у меня конфигураций (Зуп 2.5, 3.0, БП 2.0, 3.0, УТ 11.1) хоть и имеется во всех общий модуль ДополнительныеОтчетыИОбработки, но ни в одном из них нет вызываемой функции.

Вот и хочется найти таки ту конфигу, в которой таки есть такая функция и получить текст этой функции, возможно с теми вызываемыми из нее функциями, которых так же нет в стандартных конфигах.


------------------
Лень - это неосознанная мудрость.
Ratings: 0 negative/0 positive

Re: Поиск конфиги
Foxtrot

Сообщений: 3401
Откуда: Куда:
Дата: 30.03.14 20:40:32
в УправлениеНебольшойФирмой есть

// Функция возвращает таблицу значений со списком объектов метаданных,  
  // к которым может быть применена обработка переданного вида.  
  // Список объектов метаданных берется из общий команд, соответствующих  
  // виду обработки. Для глобальных обработок возвращается пустой набор.  
  // Параметры  
  // Вид - Перечисление.ВидыДополнительныхОтчетовИОбработок - вид внешней обработки  
  // Возвращаемое значение  
  // ТаблицаЗначений с колонками  
  //		ПолноеИмяОбъектаМетаданных - строка - полное имя объекта метаданных, например "Справочник.Валюты"  
  //		Класс	  - строка - класс метаданных, например "Справочник"  
  //		Объект	  - строка - имя объекта метаданных, например "Валюты"  
  //  
  Функция ПолучитьПолноеНазначениеПоВидуДополнительнойВнешнейОбработки(Вид) Экспорт  
  	  
  	Назначение = Новый ТаблицаЗначений;  
  	Назначение.Колонки.Добавить("ПолноеИмяОбъектаМетаданных");  
  	Назначение.Колонки.Добавить("Класс");  
  	Назначение.Колонки.Добавить("Объект");  
  	  
  	Команда = Неопределено;  
  	  
  	Если		Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ЗаполнениеОбъекта Тогда  
  		Команда = Метаданные.ОбщиеКоманды.ДополнительныеОтчетыИОбработкиЗаполнениеОбъекта;  
  	ИначеЕсли	Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет Тогда  
  		Команда = Метаданные.ОбщиеКоманды.ДополнительныеОтчетыИОбработкиОтчеты;  
  	ИначеЕсли	Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ПечатнаяФорма Тогда  
  		Команда = Метаданные.ОбщиеКоманды.ДополнительныеОтчетыИОбработкиПечатныеФормы;  
  	ИначеЕсли	Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.СозданиеСвязанныхОбъектов Тогда  
  		Команда = Метаданные.ОбщиеКоманды.ДополнительныеОтчетыИОбработкиСозданиеСвязанныхОбъектов;  
  	КонецЕсли;  
  	  
  	Если Команда <> Неопределено Тогда  
  		  
  		Для Каждого Тип Из Команда.ТипПараметраКоманды.Типы() Цикл  
  			ПолноеИмяОбъектаМетаданных = Метаданные.НайтиПоТипу(Тип).ПолноеИмя();  
  			РазделеннаяСтрока = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(ПолноеИмяОбъектаМетаданных, ".");  
  			НовоеНазначение = Назначение.Добавить();  
  			НовоеНазначение.ПолноеИмяОбъектаМетаданных	= ПолноеИмяОбъектаМетаданных;  
  			НовоеНазначение.Класс		= РазделеннаяСтрока[0];  
  			НовоеНазначение.Объект		= РазделеннаяСтрока[1];  
  		КонецЦикла;  
  		  
  	КонецЕсли;  
  	  
  	Возврат Назначение;  
  	  
  КонецФункции


------------------
P.S. будете проходить мимо, не стесняйтесь, проходите




Исправлено: Foxtrot, 30.03.14 20:43
Ratings: 0 negative/0 positive

Re: Поиск конфиги
ssa
Автор

Сообщений: 12329
Откуда: Москва
Дата: 30.03.14 21:26:08
Большой спасиб.


------------------
Лень - это неосознанная мудрость.
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 54 Yss-FYI Alex Roublev sphinx param  (Гостей: 50)

20.08.2019 17:51:08 exec: 0.21
Mem: 1.151 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика