for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Формирование кассовой книге по счетам и кассам
kynabo
Автор

Сообщений: 208
Дата: 11.12.12 12:33:45
Доброе время суток.
Уже голову сломала. Может кто подскажет. Кассовая книга должна формироваться по выбранным субсчетам 50.1.1, 50.1.2, 50.4 и выбранной кассе. Кассы являются субконто счета. Если я выбираю один счет остатки формируются и показываються в книге, если два или три остатков нет. Если я выбираю один счет и день где есть проведенные документы остатков опять нет. кусочек кода


НачЗапроса = ?(ПересчитатьНомера=1,НачалоГода,НачДата);  
  Ит = СоздатьОбъект("БухгалтерскиеИтоги");  
  	  
  СписокВыбСчетов = СоздатьОбъект("СписокЗначений");  
  Для к = 1 по СписокСчетов.РазмерСписка() Цикл  
  			  
  Если СписокСчетов.Пометка(к) = 1 Тогда  
  				  
  СписокВыбСчетов.ДобавитьЗначение(СписокСчетов.ПолучитьЗначение(к));  
  КонецЕсли;  
  КонецЦикла;   
    
  .........................  
    
  Ит.ИспользоватьСубконто(ВидыСубконто.ICF_Кассы,ВыбКасса);  
  		  
  Ит.ВыполнитьЗапрос(НачЗапроса, КонДата, СписокВыбСчетов,,,, "День", "СВ");  
  		  
  		  
  Запрос = СоздатьОбъект("Запрос");  
  ТекстЗапроса =  
  "//{{ЗАПРОС(КассоваяКнига)  
  |Период с НачЗапроса по КонДата;  
  |ОбрабатыватьДокументы Все;  
  |Обрабатывать НеПомеченныеНаУдаление;  
  |ПриходДок = Документ.ПриходныйОрдер.Сумма,Документ.ПриходныйОрдерТорг.Сумма;  
  |РасходДок = Документ.РасходныйОрдер.Сумма,Документ.РасходныйОрдерТорг.Сумма;  
  |Валюта = Документ.ПриходныйОрдер.Валюта, Документ.РасходныйОрдер.Валюта;  
  |СчетКассы = Документ.ПриходныйОрдер.СчетКассы,Документ.РасходныйОрдер.СчетКассы;   
  |Касса = Документ.ПриходныйОрдер.Касса, Документ.РасходныйОрдер.Касса;  
  |Функция Приход = Сумма(ПриходДок);  
  |Функция Расход = Сумма(РасходДок);  
  |Группировка День;  
  |Группировка Документ;  
  |Условие(Касса = ВыбКасса);   
  |Условие (СчетКассы в СписокВыбСчетов);  
  |";//}}ЗАПРОС		  
  КонецЕсли;  
  	  
  Запрос.Выполнить(ТекстЗапроса);
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
medstrax

Сообщений: 4474
Дата: 11.12.12 14:30:37
А ВыбКасса где определяется?
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
medstrax

Сообщений: 4474
Дата: 11.12.12 14:49:53
Если не выходит с запросом, тупо выбери все проведенные ПКО и РКО
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
kynabo
Автор

Сообщений: 208
Дата: 12.12.12 04:55:44
В ВыбКасса заносится знаечение выбранное пользователем. medstrax, спасибо большое. Кассир неправильно занесла остатки.
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
medstrax

Сообщений: 4474
Дата: 12.12.12 06:44:02
Почему я не удивлен?
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
kynabo
Автор

Сообщений: 208
Дата: 13.12.12 02:55:04
Потому что , наверное разбираетесь в людях. А что вас могло бы удивить?
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
kynabo
Автор

Сообщений: 208
Дата: 23.12.12 11:24:45
рано радовалась )С остатками ничего не получается На 50.1.1 введено новое субконто кассы. Теперь на 50.1.1 три субконто ЦФО, движение средств и кассы. Как правильно ввести остатки. Ввели остатки бухгалтерской справкой Д 50.1.1.ЦФО, Кассы К00. По ОСВ по этому счету, когда формируется оборот по субконто кассы появляются суммы на рогах. Бухгалтеру не нравится. Решили учет по кассам вести с 1.11.2012. остатки завели на 31.12.2012
Ratings: 0 negative/0 positive

Re: Формирование кассовой книге по счетам и кассам
kynabo
Автор

Сообщений: 208
Дата: 23.12.12 11:24:46
рано радовалась )С остатками ничего не получается На 50.1.1 введено новое субконто кассы. Теперь на 50.1.1 три субконто ЦФО, движение средств и кассы. Как правильно ввести остатки. Ввели остатки бухгалтерской справкой Д 50.1.1.ЦФО, Кассы К00. По ОСВ по этому счету, когда формируется оборот по субконто кассы появляются суммы на рогах. Бухгалтеру не нравится. Решили учет по кассам вести с 1.11.2012. остатки завели на 31.12.2012
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 13 AndyNigmatec  (Гостей: 12)

17.06.2019 08:41:24 exec: 0.09
Mem: 1.159 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика