for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Поиск в ТЗ по нескольким параметрам и колонкам
Skaj
Автор

Сообщений: 410
Откуда:
Дата: 24.08.12 15:40:10
Нужно осуществить поиск в ТЗ по полям Сотрудники и видВремени.
пыталась сделать с помощью .Найти(),но не знаю как там параметры задавать,как задать несколько колонок знаю,там через ",".
  
  ПерСотрудник=СокрЛП(СтрокаТаблицыЗначений.Сотрудник);  
  ПерВидВремени=СокрЛП(СтрокаТаблицыЗначений.ВидВремени);  
  ПерЧас=СтрокаТаблицыЗначений.Часов ;  
  НайденнаяСтрока=КопРабочееВремяРаботниковОрганизаций.Найти(ПерСотрудник,"Сотрудник");
,а надо по двум полям сразу.
т.е. как в параметре записать?

НайденнаяСтрока=КопРабочееВремяРаботниковОрганизаций.Найти(ПерСотрудник,"Сотрудник,ВидВремени");


------------------
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
wolf3d

Сообщений: 53
Дата: 24.08.12 16:21:21
Skaj
Нужно осуществить поиск в ТЗ по полям Сотрудники и видВремени.
пыталась сделать с помощью .Найти(),но не знаю как там параметры задавать,как задать несколько колонок знаю,там через ",".
от же упрямая - все равно по своему все
лови пример, пусть медленно - зато точно и для понимания куда рыть сойдет

  
  //таблица первоначальная  
  тв=новый таблицазначений;  
  тв.колонки.добавить("наименование");  
  тв.колонки.добавить("Кол");  
  тр.очистить();  
    
  //результирующая таблица  
  тр=новый таблицазначений;  
  тр.колонки.добавить("наименование");  
  тр.колонки.добавить("Кол");  
  тр.очистить();  
    
  // загрузка ТЗ из справочника  
  выб=справочники.Товары.Выбрать();  
  пока выб.следующий() цикл  
     ОбработкаПрерыванияПользователя();  
     вв=тв.добавить();  
     вв.наимен= выб.наименование;  
     вв.кол = выб.количество;  
  КонецЦикла;  
    
  //отбор по наименованию "Вася" и количеству >= 5  
    
  для каждого т из тв цикл  
     флаг=0;  
     если т.наименование = "Вася" тогда  
         флаг=1;  
     КонецЕсли;  
     если т.кол >= 5 тогда  
         флаг=флаг+1;  
     КонецЕсли;  
     если флаг =2 тогда  
         вв2=тр.добавить();  
         вв2.наименование=т.наименование;  
         вв2.кол=т.кол;  
     КонецЕсли;  
  КонецЦикла;
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
medstrax

Сообщений: 4474
Дата: 24.08.12 16:25:55
Нафига что-то читать, если проще спросить, правда?
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
wolf3d

Сообщений: 53
Дата: 24.08.12 16:32:21
medstrax
Нафига что-то читать, если проще спросить, правда?
да не - думаю таки пытаеться делать - просто невыходить)))

и кстати - если я больше забыл чем некоторые знали - то мне прощще спросить чем заново учить)

зы. правда все конфы сохранены - обычно поднимаю и смотрю как ваял)))



Исправлено: wolf3d, 24.08.12 16:39
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
Skaj
Автор

Сообщений: 410
Откуда:
Дата: 24.08.12 22:08:14
medstrax
Нафига что-то читать, если проще спросить, правда?
Неправда. Я искала в книгах и справочниках. Там пример только с одним параметром.

------------------
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
Skaj
Автор

Сообщений: 410
Откуда:
Дата: 24.08.12 22:09:57
wolf3d
medstrax
Нафига что-то читать, если проще спросить, правда?
да не - думаю таки пытаеться делать - просто невыходить)))

и кстати - если я больше забыл чем некоторые знали - то мне прощще спросить чем заново учить)

зы. правда все конфы сохранены - обычно поднимаю и смотрю как ваял)))
Прежде чем задать вопрос на форуме -я ищу в книгах и стандартной конфигурации, но там нет ничего.


------------------
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
wolf3d

Сообщений: 53
Дата: 25.08.12 05:06:02
[quote Skaj][/quote]
Прежде чем[/quote]
...задавать вопрос - я прочел справку встроенную в конфигуратор 1с
...задавать вопрос - я попробовал реализовать свою задачу своими силами - результатом оказалось что мои решения намного лучше разработчиков 1с
...задавать вопрос - я покурил много форумов

и тд...

ЗЫ. скажи как выглядит моя аватарка



Исправлено: wolf3d, 25.08.12 05:09
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
Сергей_Л

Сообщений: 17849
Откуда: Киров(Вятка)
Дата: 25.08.12 22:36:11
medstrax
Нафига что-то читать, если проще спросить, правда?
Ну зачем уж так сразу наезжать на девушку, просто она хотела использовать стандартную функцию но не получилось.
Тогда делаем по рабоче-крестьянски, организуем цикл по таблице и проверяем на совпадение сразу двух параметров.


------------------
«Не причиняй зла никому и делай добро всем людям, хотя бы только потому, что это люди.»
(Марк Туллий Цицерон)
Ratings: 0 negative/0 positive

Re: Поиск в ТЗ по нескольким параметрам и колонкам
medstrax

Сообщений: 4474
Дата: 26.08.12 05:07:55
Сергей_Л
Ну зачем уж так сразу наезжать на девушку
Это наезд не на девушку, а на способ изучения. Неужели трудно открыть синтакс-помощник и увидеть функу НайтиСтроки()? Впрочем, эта функа ищет только на равенство, других условий задать нельзя, это неудобно иногда.
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 4 Taran Igor Korolyov  (Гостей: 2)

22.09.2019 23:18:25 exec: 0.1
Mem: 1.222 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика