for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Обработка для отбора дублирующих кодов
Skaj
Автор

Сообщений: 410
Откуда:
Дата: 10.08.12 13:26:03
Всем привет. Я только учусь программированию на 1С. Это мое первое задание. не могу понять почему не работает. Ошибок не выдает. Но и не работает. Написала внешнюю обработку для отбора дублирующих кодов в Справочнике СотрудникиОрганизации,и еще чтоб выводила сообщение где код не верной длины.
Предупреждение ("1") ;  
  мТабНом="0000000000";  
  СотрудникиОрганизаций=Справочники.СотрудникиОрганизаций;  
  Отбор = Новый Структура("Код");  
    
  Выборка = СотрудникиОрганизаций.Выбрать(,,Отбор, "Код Возр");  
  Пока Выборка.Следующий()  Цикл  
  	 Предупреждение ("2")   ;  
    
  	   // проверяем на дублирование табельного номера  
  	   Если    Выборка.код=мТабНом     Тогда  
  		    Предупреждение ("3")  ;  
    
  			    Предупреждение ("Табельный номер не уникален - "  + мТабНом);  
  			КонецЕсли;  
              мТабНом=  Выборка.код;  
  			// определяем длину табельного номера  
  			длТабНом=СтрДлина (СокрЛП (мТабНом));  
  			Если   длТабНом<10     Тогда  
  				 Предупреждение ("4") ;  
    
  			    Предупреждение ("Неверная длина табельного номера - "  + мТабНом);  
  			КонецЕсли;  
    
    
  КонецЦикла;
Предупреждение - сделала для отладки-чтоб увидеть попадает она впрограмму или нет. так,вот она показывает только первое предупреждение. Остальные нет. Следовательно та часть не работает. Помогите плиз


------------------
Ratings: 0 negative/0 positive

Re: Обработка для отбора дублирующих кодов
Skaj
Автор

Сообщений: 410
Откуда:
Дата: 10.08.12 13:56:17
решила проблему


------------------
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 9 Taran GotFocus  (Гостей: 7)

16.09.2019 17:22:25 exec: 0.08
Mem: 1.082 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика