for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Лисоводы   всех   стран,  объединяйтесь !!!  

Список Форумов  :: Вопросы по 1С
  

Как програмно изменить значение ресурса в регистре сведений?
Myhailo
Автор

Сообщений: 748
Дата: 07.12.11 09:50:00
Здравствуйте, уважаемые коллеги.

В регистре сведений есть два измерения Сотрудник и НомерТелефона, требуется прибавить к номеру телефона спереди код оператора, подскажите пожалуйста в стиле форума как это сделать.

Спасибо.
Ratings: 0 negative/0 positive

Re: Как програмно изменить значение ресурса в регистре сведений?
Myhailo
Автор

Сообщений: 748
Дата: 07.12.11 14:46:16
Процедура КнопкаВыполнитьНажатие(Кнопка)  
  ДатаЗаписи='20080101';  
  НаборЗаписей = РегистрыСведений.НомераТелефоновСотрудников.СоздатьНаборЗаписей();  
  НаборЗаписей.Отбор.Период.Установить(ДатаЗаписи);   
  НаборЗаписей.Прочитать();   
  Для Каждого Запись Из НаборЗаписей Цикл   
     Если СтрДлина(СокрЛП(Запись.Номер))=9 тогда  
  	   // Чтение и сообщение данных полей записи.  
  	   Сообщить(Строка(Запись.Период) + " " + Строка(Запись.Номер));   
         // Изменение данных полей записи.  
  	   Запись.Номер = Число("67"+Строка(Запись.Номер));  
     КонецЕсли;		  
  КонецЦикла;   
  НаборЗаписей.Записать();  
  Закрыть(ЭтаФорма);  
    КонецПроцедуры
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут оставлять сообщения в этом форуме.

On-line: 16 Simple777  (Гостей: 15)

17.09.2019 13:40:46 exec: 0.09
Mem: 1.081 Mb

© 2000-2019 Fox Club 
Яндекс.Метрика