for flooders
:: Главная :: Решения :: Статьи :: Сайт М. Дроздова :: Файловый архив :: Книга по VFP 9 :: Русский Help Online :: OFF-LINE Форум
   Л и с о в о д ы   в с е х   с т р а н,  о б ъ е д и н я й т е с ь !!!  

Список Форумов  :: Visual Foxpro, Foxpro for DOS
   :: Помощь сайту :: 

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 26.06.17 12:12:34ОтветитьЦитировать
До 01.07 считанные дни. А проблемы остались.
И как полагаю, у всей страны))))
Тут уже звучал вопрос про Тег 1214.
Никто не отреагировал)
Так как его решаете?

Есть мысль, просто завести строку "Аванс"
И ее в чек пробивать.
(Непонятно что делать со стоимостью((( сделать 1коп.?
Тогда количество замучаешься писать)))
)


------------------
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Василий

Сообщений: 655
Откуда: Москва
Дата: 26.06.17 12:23:07ОтветитьЦитировать
Аспид
Тут уже звучал вопрос про Тег 1214.
Никто не отреагировал)
Так как его решаете?
Это обязательный тэк ФФД 1.05.
Я на него пока забил.
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 26.06.17 12:41:30ОтветитьЦитировать
Василий
Это обязательный тэк ФФД 1.05.
Я на него пока забил.
Ну 1.05 действует с марта.
Забить легко)
А гл. бух переживает)))
Но в описании на драйвер такого тега не нашел.
Равиль пробовал - не работает)
Так как мой способ. Имеет смысл?

В дополнение, есть еще Чек коррекции.
С ним тоже мне все мозги вынесли!
А может я просто чего то не знаю, и его можно как то сделать?


------------------




Исправлено: Аспид, 26.06.17 12:42
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 26.06.17 12:43:02ОтветитьЦитировать
Аспид
До 01.07 считанные дни. А проблемы остались.
И как полагаю, у всей страны))))
Тут уже звучал вопрос про Тег 1214.
Никто не отреагировал)
Так как его решаете?

Есть мысль, просто завести строку "Аванс"
И ее в чек пробивать.
(Непонятно что делать со стоимостью((( сделать 1коп.?
Тогда количество замучаешься писать)))
)

Да, это вариант )) завести позицию "Аванс" с ценой 1 рубль и продавать количество равное Авансу,
а при расчете делать возврат Аванса и реализацию реального товара на всю сумму.


------------------
Тяжело согнать курсором муху с монитора ...
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Василий

Сообщений: 655
Откуда: Москва
Дата: 26.06.17 12:55:27ОтветитьЦитировать
Аспид
Ну 1.05 действует с марта.
Забить легко)
А гл. бух переживает)))
Но в описании на драйвер такого тега не нашел.
То что действует с марта, кстати как и формат 1.1, но по этому поводу Ваш бух не паникует,
не отменяет что формат 1.0 действует до 01/01/2019

Для того чтобы данные передавались по формату 1.05
этот формат должен поддерживать ОФД (думаю все уже поддерживают)
Прошивка ФР, вот затрудняюсь сказать должен ли ФН поддерживать этот формат.

Как говорили на конференциях АТОЛ чек коррекции это для корректировки добровольной, когда нашли ошибку и "вынужденной" когда найдет "органы".

Раньше то как обходились?
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 26.06.17 13:04:13ОтветитьЦитировать
Василий
То что действует с марта, кстати как и формат 1.1, но по этому поводу Ваш бух не паникует,
не отменяет что формат 1.0 действует до 01/01/2019

Не. У нее ж своя свадьба.
Она читает доки (законы), и там написано. "Должно..." и... "действует с момента публикации "
И дела им нет, что это технически не реализуемо)))

Про чек коррекции так просто написал. Достала она)

Именно, что раньше легко обходились)


------------------




Исправлено: Аспид, 26.06.17 13:05
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 26.06.17 13:05:34ОтветитьЦитировать
Аспид
Василий
Это обязательный тэк ФФД 1.05.
Я на него пока забил.
Ну 1.05 действует с марта.
Забить легко)
А гл. бух переживает)))
Но в описании на драйвер такого тега не нашел.
Равиль пробовал - не работает)
Так как мой способ. Имеет смысл?

В дополнение, есть еще Чек коррекции.
С ним тоже мне все мозги вынесли!
А может я просто чего то не знаю, и его можно как то сделать?

Может он и действует, тут уже и 1.1 утвердили )) но обязательным к исполнению он будет с 01.01.2018
А пока идет переходный период, с трудностями поддержки всех форматов как со стороны производителей прошивок ККМ так и со стороны ОФД.
В это время думаю главное соблюсти арифметику )) поэтому по поводу Аванса (частичной оплаты) делал еще один вариант - "пропорциональный чек"
Допустим клиент берет 1 шт. по 100 руб., оплачивает 40 руб. - в чеке будет 0.4 шт по 100 руб
Все цифры сходятся


------------------
Тяжело согнать курсором муху с монитора ...
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 26.06.17 13:46:44ОтветитьЦитировать
Равиль
Допустим клиент берет 1 шт. по 100 руб., оплачивает 40 руб. - в чеке будет 0.4 шт по 100 руб
Все цифры сходятся

Супер. Особенно автомобилями торговать))))

Но тем не менее, все по закону. Решение верное!


------------------




Исправлено: Аспид, 26.06.17 13:47
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 26.06.17 14:31:09ОтветитьЦитировать
Кстати, никто не сталкивался с ограничением количества строк в одном чеке ? Есть ли оно ?
У меня сейчас на Атол 55Ф бодренько вышел чек на 106 наименований (около 350 строк)


------------------
Тяжело согнать курсором муху с монитора ...
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
ssa
[Модератор]

Сообщений: 11982
Откуда: Москва
Дата: 26.06.17 15:13:00ОтветитьЦитировать
Равиль
Кстати, никто не сталкивался с ограничением количества строк в одном чеке ? Есть ли оно ?
У меня сейчас на Атол 55Ф бодренько вышел чек на 106 наименований (около 350 строк)
Более 200 наименований. Штрих-М01Ф. Время печати < 2 сек.

------------------
Лень - это неосознанная мудрость.
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 26.06.17 16:28:35ОтветитьЦитировать
ssa
Равиль
Кстати, никто не сталкивался с ограничением количества строк в одном чеке ? Есть ли оно ?
У меня сейчас на Атол 55Ф бодренько вышел чек на 106 наименований (около 350 строк)
Более 200 наименований. Штрих-М01Ф. Время печати < 2 сек.

Шустрый аппарат у тебя.
Где-то слышал про ограничение на чековый буфер, но похоже до дна далеко,
сейчас не пожалел ленту - 4 метра - тестовая накладная 303 наименования - за 12 секунд ))


------------------
Тяжело согнать курсором муху с монитора ...
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 27.06.17 06:45:34ОтветитьЦитировать
Ну ребята у вас магазины)))
А у меня 4 позиции, предел) И то раз в год.
1 иногда 2 позиции.
Там больше, всякий QR и прочая мура занимает.


------------------
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
ssa
[Модератор]

Сообщений: 11982
Откуда: Москва
Дата: 27.06.17 09:22:29ОтветитьЦитировать
Аспид
Ну ребята у вас магазины)))
Кто тебе сказал такую чушь? Обычная оптовка, но некоторым юрлицам удобнее оплачивать наличкой.


------------------
Лень - это неосознанная мудрость.
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
EAF

Сообщений: 5
Дата: 27.06.17 09:40:47ОтветитьЦитировать
подскажите где можно скачать инструкцию по программированию АТОЛ 30Ф. если у кого есть скиньте, пожалуйста.
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 27.06.17 15:44:07ОтветитьЦитировать
EAF
подскажите где можно скачать инструкцию по программированию АТОЛ 30Ф. если у кого есть скиньте, пожалуйста.
Так полистай тему, где-то недалеко ссылки есть.
Ясное дело, что конкретно на 30Ф нет, поскольку руководство для всех одно.

Ввел кассу в реальный режим с ФН.
Везде зарегил.
На 1м чеке напечатано
Чек № 1
...
ФД 000000003

Как это понимать?


------------------
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
ssa
[Модератор]

Сообщений: 11982
Откуда: Москва
Дата: 27.06.17 15:48:59ОтветитьЦитировать
Аспид
EAF
подскажите где можно скачать инструкцию по программированию АТОЛ 30Ф. если у кого есть скиньте, пожалуйста.
Так полистай тему, где-то недалеко ссылки есть.
Ясное дело, что конкретно на 30Ф нет, поскольку руководство для всех одно.

Ввел кассу в реальный режим с ФН.
Везде зарегил.
На 1м чеке напечатано
Чек № 1
...
ФД 000000003

Как это понимать?
Что ЭТО? ФД не 00000001? Так еще есть отчет о фискализации. Получи из фискальника документы с номерами 1 и 2 ми изучи.

------------------
Лень - это неосознанная мудрость.
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
EAF

Сообщений: 5
Дата: 29.06.17 09:33:12ОтветитьЦитировать
Здравствуйте, уважаемые ...!

Мы сделали с помощью примера базы данных на 1С:Предприятие 7.7, поставляемой вместе с драйвером АТОЛ30Ф модуль в нашем документе "Чек" для
1С:Торговля и склад 7.7 (документ отдельный и не совпадает с типовым документом "ЧекККМ", так как есть особенности внедрения работы без розницы).

Чек печатается, но не закрывается, поэтому следующий за ним чек без куска модуля
"
// если есть открытый чек, то отменяем его
Если ECR.CheckState <> 0 тогда
Если ECR.CancelCheck() <> 0 тогда
Возврат;
КонецЕсли;
КонецЕсли;
"
не печатается.

В блоке
" //закрываем чек
Если ECR.CloseCheck() <> 0 тогда
Сообщить(ECR.ResultCode);
Возврат;
КонецЕсли;
//
"
выдаёт сообщение с кодом ошибки "-3897".

Вопрос: в чём наша ошибка и как правильно закрыть чек?

Заранее спасибо!

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

// занимаем порт
ECR.DeviceEnabled = 1;
Если ECR.ResultCode <> 0 тогда
Возврат;
КонецЕсли;

// получаем состояние ККМ
Если ECR.GetStatus() <> 0 тогда
Возврат;
КонецЕсли;

// если есть открытый чек, то отменяем его
Если ECR.CheckState <> 0 тогда
Если ECR.CancelCheck() <> 0 тогда
Возврат;
КонецЕсли;
КонецЕсли;

// входим в режим регистрации
// устанавливаем пароль кассира
ECR.Password = "1";
// входим в режим регистрации
ECR.Mode = 1;
Если ECR.SetMode() <> 0 тогда
Возврат;
КонецЕсли;

//формируем собственно чек ККМ

//перечислим позиции
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
ECR.Name = Номенклатура.Наименование;
ECR.Price = Цена;
ECR.Quantity = Количество;
//ECR.Department = 1;
Если ECR.Registration() <> 0 тогда
Сообщить("Ошибка регистрации позиции номенклатуры ...");
Возврат;
КонецЕсли;
КонецЦикла;

//оплата наличными
ECR.Summ = СуммаНаличными;
ECR.TypeClose = 0;

Если ECR.Payment() <> 0 Тогда
Сообщить("Проблемка оплаты наличными ...");
КонецЕсли;

//оплата по карте
ECR.Summ = СуммаПоКарте;
ECR.TypeClose = 1;

Если ECR.Payment() <> 0 Тогда
Сообщить("Проблемка оплаты по карте ...");
КонецЕсли;
//

//закрываем чек
Если ECR.CloseCheck() <> 0 тогда
Сообщить(ECR.ResultCode);
Возврат;
КонецЕсли;
//
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Аспид

Сообщений: 3032
Откуда: Москва
Дата: 29.06.17 10:07:53ОтветитьЦитировать
Читать неудобно.
Сообщение мало информативно.
EAF
выдаёт сообщение с кодом ошибки "-3897".
А что это значит, мы должны искать?
Уж поищите сами.

И как мне кажется, у вас ошибка в логике формирования чека.
  
  //оплата наличными   
  ECR.Summ = СуммаНаличными;   
  ECR.TypeClose = 0;   
    
  Если ECR.Payment() <> 0 Тогда   
  Сообщить("Проблемка оплаты наличными ...");   
  КонецЕсли;   
    
  //оплата по карте   
  ECR.Summ = СуммаПоКарте;   
  ECR.TypeClose = 1;   
    
  Если ECR.Payment() <> 0 Тогда   
  Сообщить("Проблемка оплаты по карте ...");   
  КонецЕсли;   
  //


------------------
Ratings: 0 negative/0 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 29.06.17 17:40:56ОтветитьЦитировать
Аспид
До 01.07 считанные дни. А проблемы остались.
И как полагаю, у всей страны))))
Тут уже звучал вопрос про Тег 1214.
Никто не отреагировал)
Так как его решаете?

Есть мысль, просто завести строку "Аванс"
И ее в чек пробивать.
(Непонятно что делать со стоимостью((( сделать 1коп.?
Тогда количество замучаешься писать)))
)

в №13 Главбуха: e.glavbukh.ru

Цитата:
Новости
Что изменилось
Минфин рассказал, как пробить чек на аванс
Главное изменение: в чеке на предоплату можно не приводить название товара, цену и количество. Достаточно пометки «Аванс».

Осторожно
Если продавец может определить, за что покупатель вносит предоплату, то на чеке надо привести список товаров.
Чеки на предоплату пробивайте с признаком расчета «Аванс». Указывать наименование товара, цену и количество не обязательно. Но при одном условии — объем и список товаров в момент оплаты определить нельзя. К такому мнению пришли в Минфине (письмо от 28 апреля 2017 г. № 03-01-15/26352).

С 1 июля большинство компаний должны пробивать чеки на новых онлайн-кассах. Среди обязательных реквизитов такого чека — наименование товара и его количество (ст. 4.7 Федерального закона от 22 мая 2003 г. № 54-ФЗ). Но продавец не всегда может определить, за что покупатель вносит деньги в качестве предоплаты. Чиновники ввели новый признак способа расчета — «Аванс» (табл. 28 к приказу ФНС России от 21 марта 2017 г. № ММВ-7-20/229). Образец 1.

Бухгалтер компании-покупателя должен внимательно изучить чек. Ведь расходы в момент оплаты аванса признавать нельзя. Это делают после того, как продавец отгрузит товары (п. 14 ст. 270 НК РФ).

Когда покупатель получит товары и окончательно рассчитается, пробейте ему еще один чек. В нем приведите все оплаченные товары, их наименование и цену. Оформите чек на сумму, которую получили от покупателя. Указывать в нем аванс не надо. Образец 2.

+
Как мы узнали у производителей ККТ, скоро они доработают кассовые программы и на чеках появятся дополнительные реквизиты из нового приказа ФНС (приказ от 21 марта 2017 г. № ММВ-7-20/229). Среди них есть «Сумма по чеку предоплатой (зачет аванса)». То есть аванс, который продавец получал от покупателя раньше, будет отражаться в чеке


ps Так что строки типа "АВАНС" или "ПРЕДОПЛАТА" или "ПЕРВОНАЧАЛЬНЫЙ ВЗНОС" будут вполне уместными вместо полного перечня товаров,
а когда "производители ККТ скоро доработают кассовые программы"
и когда мы дружно перепрошьем свои ККМ под новые протоколы, тогда можно будет указывать в чеках "зачет аванса" и прочее-прочее ..

ps2 ссылка на Образцы чеков: e.profkiosk.ru
не знаю откроется ли у вас, у меня демо-доступ на 3 дня )) - у нас что правовая информация платная ? )))

Нарисовать красиво можно все-что угодно, но как они себе представляют закрытие Второго чека (в рамках протокола 1.00), в котором сумма покупки 3000, а оплата 1820


------------------
Тяжело согнать курсором муху с монитора ...




Исправлено: Равиль, 29.06.17 18:08
Ratings: 0 negative/1 positive

Re: Новая касса АТОЛ -30Ф
Равиль

Сообщений: 6233
Откуда: Уфа
Дата: 29.06.17 17:57:10ОтветитьЦитировать
EAF
...
выдаёт сообщение с кодом ошибки "-3897".
Вопрос: в чём наша ошибка и как правильно закрыть чек?

Описание ошибок можно посмотреть в файле Drivers8_FprnM_PM.pdf, который идет в составе документации к драйверу
или прочитать в свойстве ECR.ResultDescription
–3897 Чек оплачен не полностью, то есть ваши СуммаНаличными + СуммаПоКарте не закрывают сумму покупки


------------------
Тяжело согнать курсором муху с монитора ...
Ratings: 0 negative/0 positive



Извините, только зарегистрированные пользователи могут писать в этом форуме.

On-line: 29 comsel  and Guests: 28


© 2000-2018 Fox Club 
Яндекс.Метрика